Hi Steve,
I am still struggling with the new structures for city/zip codes.
We may add new fields like
leftCity,rightCity,leftZip,rightZip to class Numbers,
but I'd prefer to change the code completely.
Instead of the left/right prefix I'd prefer to have
class Numbers{
int start,end;
NumberStyle style;
CityInfo city; // class CityInfo contains fields city,region,country
String zip;
}
and a higher class,e,g.
class RoadNumbers{
int nodeNumber, rnodNumber ; // do we need both?
Numbers left,right;
}
and finally in RoadDef:
List<RoadNumbers> numbers;
What do you think about that?
Gerd